Cydia
How to manually install Cydia if you accidentally deleted itimgur

Jailbreak developers can now mark their tweaks as iOS 8.3 compatible.

Until now the developers were not having the ability to mark their jailbreak tweaks, since saurik want to ensure the stability of the TaiG iOS 8.3 jailbreak.

During installation from Cydia you might have seen a warning message that reads, "This product is not currently certified to be compatible with your device." This message appears on all paid tweaks in Cydia, which means they are not enabled for iOS 8.3.

TaiG has recently rolled out an update, version 2.1.2, to its untether jailbreak tool with support for Cydia Substrate and addresses all the error found in the previous release. Besides, the TaiG 8.1.3-8.x Untether version 2.1.2 package available in Cydia as an update.

With the stable release of the TaiG jailbreak utility, Cydia is now officially open for iOS 8.3 compatible tweaks, and users can purchase Cydia tweaks that are updated.

Springtomize 3 for iOS 8.3 jailbreak

Filippo Bigarella, the developer of the popular jailbreak tweak, Springtomize 3 has said that it will be updated to support iOS 8.3. While Filippo will not be a part of the development due to the time constraints, he ensures that the updated version is expected soon.

Springtomize 3, with plenty of options, customises your iOS device to a very high degree. The app has been localised in 20 different languages.

Until an updated version of Springtomize 3 comes out, you can take advantage of more than 100 iOS 8.3 jailbreak compatible tweaks.

Via iDownloadblog