iOS 6.1.3
OdysseusOTA allows downgrading iPhone 4S and iPad 2 to iOS 6.1.3 without SHSH blobsMacgasm

The iOS hacker who runs the Twitter handle tihmstar has created a tool called OdysseusOTA using which he has successfully performed a downgrade of Apple's older devices such as iPhone 4S and iPad 2 to iOS version 6.1.3.

Hacker tihmstar claims to have created this tool, which does not require SHSH blobs for the downgrade, with the help of well known iOS hackers iH8sn0w and winocm.

As tihmstar explains, the downgrade is possible only on iPhone 4S and iPad 2 as Apple is still signing iOS 6.1.3 for both the devices, which use 1GHz A5 dual-core Cortex-A9 processor.

While the OdysseusOTA tool for iPhone 4S is currently live, the hacker promises to add the same for iPad 2 soon.

To clear up the confusion: This tool will only work on devices that have been on iOS 5.0.1 or (possibly) iOS 5.1.1. This means that only the iPad 2 and the iPhone 4S is supported.
Why? Because Apple made a mistake in their code and devices that are on one of the two mentioned iOS's MUST update to iOS 6.1.3 (if they are updating via OTA) in order for their deceive to be able to update to latest iOS version.

Can Apple stop people from using this exploit?

No because then devices on iOS 5.0.1 or iOS 5.1.1 would not be able to update via OTA. I hope this clears up confusion.

To perform the downgrade all you need for this a jailbroken iPhone 4S and iOS 6.1.3 firmware to perform the downgrade.
Troubleshoot

If you are a Linux user install this to fix some errors.

If you happen to own an iPhone 4S, you can take advantage of the OdysseusOTA for downgrading to the older iOS version.

In case you are sceptical about the downgrade method, check out the following video walkthrough.

Source: Reddit